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DCPDS 
(Web-Based Version – Oracle 11i)

Quick Start Guide

Overview
	Introduction
	This guide explains the initial steps to navigate Oracle 11i, the web-based version of DCPDS.  New features in 11i include:

· Required fields are highlighted.

· List of Values (LOVs) are embedded with the data fields.

· Date format allows for free form entry, which is automatically converted to the correct system format.

· Tabs have replaced many flexfields.

· A Person Summary for viewing all the employee data.

· A Position History for viewing changes to the position record.

· Less down time – no client loads for patches.
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	Modern DCPDS User Guide posted on the DoD CPMS Home Page for specific processing details.


	Before You Begin
	· Obtain a User Name.

· Set up your secure password.

· Ensure you are:

· Assigned the Workflow Inbox responsibility to view your inbox.


	System Maintenance
	Because Oracle 11i is web-based, files are added to your temporary internet file folder.  You should periodically purge this folder.  Use the following steps: 


	Step
	Action

	1
	In the Internet Browser, click Tools/Internet Options on the Main Toolbar. The Internet Options Window displays.  In the middle Region, “Temporary Internet Files,” states:  “Pages you view on the internet are stored in a special folder for quick viewing later.”

	2
	Click <Delete Files.>  The Delete Files Window Displays.

	3
	Click <OK>.


System Changes/New Features

	Purpose
	This section explains some of the system changes and new features in 11i and the action required to use them.


	System Changes/Description/Function
	


	System Changes
	Description/Function

	Switch Responsibility


	Replaced with a new icon on the toolbar (a derby hat).
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	System Times Out
	Leave the Oracle picture on the screen, right click on the mouse and click “Refresh” on the menu.  Saves logging on again.  

	Function Key F8 is now F11 + CTRL F11
	For Query:  

· Place the cursor in the first blank data field.

· Press F11 and then Ctrl and F11 simultaneously.

	List of Values (LOVs)
	Are located within most windows.

	Wild Cards
	Wildcards are software tools that enable you to define a range of values that begin with, end with, and/or include specific letters, numbers, words, or phrases .i.e.

· You may want to conduct a query of all the employees whose last name starts with the letter L.

· You may forget how to spell an employee’s name and want to look up all of the employees whose last name ends in the letters th.

· You may want to look up all of the employees that have a birth date in the month of April.

The wildcard symbol in Oracle is the percent symbol on your keyboard (%).  Wildcards can be used in any field that Oracle permits you to access while in the query mode.  

	Data fields 
	Color denotes functionality:

	
	
	Color
	Types of Data Fields

	
	
	Blue
	Query 

	
	
	Yellow
	Required 

	
	
	White
	Optional

	
	
	Gray
	Cannot be entered 


Continued on next page

System Changes/New Features, Continued

	System Changes/Description/Function (continued)


	System Changes
	Description/Function

	If you cancel a realignment:
	The employee goes back to previous position.

	New HR Manager Navigator Menu Items:
	Career Management:  (Rating Scales, Competencies, Competence Types, Competence requirements, Schools & Colleges, Qualification Types, Assessment Template, and Appraisal Template.)

	Record Types


	Employee – Ex Applicant:  Someone appointed  

                     and hired in DCPDS.

Employee:  Someone who was converted from Legacy or moved from one region to another (Mod to Mod).

	Tabs
	Replaced alternate regions

	Position has enhanced Date Tracking
	You can view all the history of changes that have occurred on a position.

	RPA, Salary Change, Awards and Mass Awards
	System calculates percentages.


Logging On

	Purpose
	This section shows you how to log on to Oracle 11i.


	Logging On
	Follow these steps to log on:

	Step
	Action

	[image: image1.bmp]1
	Click on the Oracle 11i Icon on your desktop.  The Oracle Rapid Install Release 11i Web Page displays:
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	2
	Click <Apps Logon Links>.  The right side of the window populates:  
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Continued on next page

Logging On, Continued

	Logging On (continued)


	Step
	Action

	3
	Click <Personal Home Page>.  The Oracle Application Login Window displays:
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	4
	Type your assigned User Name in the User Name field.  

	5
	In Password, type in “Password.”  Click <Connect> (or Enter).

	6
	· If you have established an 11i Password, disregard this step.

· If you have not established an 11i Password, a screen will display which will ask you to type in the old (“Password”) and your own unique password (twice).  Click the <Connect> button. 

	7
	The Welcome Window displays with the roles assigned to you.


Navigating 

	Purpose 
	This section shows how to navigate through Oracle 11i.


	Welcome Window
	


	Step
	Action

	1
	On the Welcome Window, select your role and double click.  For example:  “CIVDOD PERSONNELIST.”
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Continued on next page

Navigating, Continued

	Welcome Window (continued)


	Step
	Action

	2
	The Oracle Application 11i Window displays as it is connecting, stating:  “Loading Java Applet.”
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Note:  The desk top bottom toolbar displays: e Oracle Appl.

	3
	If you have actions in your inbox, a notification displays:
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Refer to the Workflow Inbox section in this guide to work these actions after you open the Navigation List.  Click the <OK> button.
Note:  Ignore the hour glass which stays on.  




Continued on next page

Navigating, Continued

	Navigator Window

	Step
	Action

	1
	The Navigation window displays two tabs (Functions and Documents).  This list of functions is the starting point to process actions, build positions, maintain employee records, run reports, etc.
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	Part
	Description
	

	
	
	Functions Tab
	Displays the Navigation List starting with the RPA, or OTA, etc.,  depending on which role you are in. 
	

	
	
	Documents Tab
	Not currently used by DoD. 
	

	
	
	Navigation List
	Displays all the items that may be performed.  
	

	2
	You may click on the plus sign to expand the functions and the minus sign to contract them.  
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Double click on the item to start a process, or click <Open>.


Continued on next page

Navigating, Continued

	Navigator Window continued)


	Step
	Action

	3
	To set up a Top Ten List of your most frequently performed actions, highlight the item on the list and click the middle arrow key to the right.  The item displays under “Top Ten List.”

For example:  Highlight Workflow Inbox and click the arrow key.  The Top Ten List populates with “1.  Customizable Workflow Worklist.” 
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To view your inbox in the future, you only need to type a “1” to open the Work list.


Toolbar Icons, Functions, and Shortcut Keys

	Toolbar Icons 
	Click the Icon on the toolbar to display the function: 
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	Functions, Shortcut Keys, and Icons in Alphabetical Order:
	


	Functions
	Shortcut Keys/ Icons
	
	Functions
	Shortcut Keys/  Icons

	Alter Effective Date (calendar)
	[image: image14.bmp]
	
	Find (flashlight) 
	[image: image15.bmp]

	Attachments (paper clip)
	[image: image16.bmp]
	
	Folder Tools
	[image: image17.bmp]

	Block Menu
	Ctrl+B
	
	List of Values
	Ctrl+L

	Clear Block
	F7
	
	List Tab Pages
	F2

	Clear Field
	F5
	
	Next Block
	Shift+PageDown

	Clear Form
	F8
	
	Next Field
	Tab

	Clear Record
	F6
	
	Next Primary Key
	Shift+F7

	Commit/Save
	Ctrl+S
	
	Next Record
	Down

	Clear Record (Pencil eraser)
	[image: image18.bmp]
	
	Export Data (document w/blue arrow)
	[image: image19.bmp]

	Count Query
	F12
	
	List of Values
	Ctrl+L

	Copy (documents)
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	List Tab Pages
	F2

	Close Form (yellow folder w/blue arrow)
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	New (green plus)
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	Cut (scissors)
	[image: image23.bmp]
	
	Next Step (arrows on document)
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	Date Track History
	[image: image25.bmp]
	
	Next Set of Records
	Shift +F8

	Delete Record
	Ctrl+Up
	
	Previous Block
	Shift+PageUp


Continued on next page

Toolbar Icons, Functions, and Shortcut Keys, Continued

	Functions, Shortcut Keys, and Icons in Alphabetical Order: (continued)


	Function
	Shortcut/ Icon
	
	Function
	Shortcut/Icon

	Delete (Red X)
	[image: image26.bmp]
	
	Previous Field
	Shift+Tab

	Display Error
	Shift+Ctrl+E
	
	Previous Record
	Up

	Down
	Down
	
	Print
	Ctrl+P

	Duplicate Field
	Shift+F5
	
	Print (printer)
	[image: image27.bmp]

	Duplicate Record
	Shift+F6
	
	Return
	Return

	Edit (pencil)
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	Save (yellow disc)
	[image: image29.bmp]

	Edit
	Ctrl+E
	
	Show Navigator- returns to Menu
	[image: image30.bmp]

	Enter Query
	F11 (Press twice to   

       display last query)
	
	Help
	Ctrl+H

	Execute Query
	Ctrl+F11 (Use for blind queries to retrieve all records)
	
	Insert Record
	Ctrl+Down

	Exit
	F4
	
	Translations
	Not used

	Paste
	[image: image31.bmp]
	
	More Information Available 
	<   >

	Window Help (blue question mark)
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	Zoom
	Not used

	Switch 

Responsibility 
	[image: image33.png]



	
	
	


Other Functions of the Oracle Applications Window

	Window Functions
	· Message Line: Oracle Applications display pertinent information for processing your form, including error messages.
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· Record Indicator: Display the information about how many records are retrieved in your query and which record is currently opened.  For example, in the above screen you are in the 10th record of a total of 71 records.




	Menu Bar
	There is a series of pull-down menus at the top of the window. You can operate the pull-down menu using either keyboard shortcuts or the mouse.  On the keyboard, use the Alt key to drop down the menu (e.g. Alt + Q for the Query Menu), the Down Arrow to move to the option required, and then Enter to execute.




Continued on next page

Other Functions of the Oracle Applications Window, Continued

	Menu Options
	


	File
	Edit
	View
	Folder
	Tools
	Window
	Help

	New
	Undo Typing
	Show Navigator
	New
	Options change depending on the application and form in use.
	Cascade
	Window Help

	Open
	Cut
	Zoom
	Open
	
	Tile Horizontally
	Oracle Applications Library

	Save
	Copy 
	Find
	Save
	
	Tile Vertically
	Keyboard Help

	Save and Proceed
	Paste
	Find All
	Save As
	
	List of Open Windows
	Diagnostics

	Next Step
	Duplicate
	Query by Example
	Delete
	
	
	Record History

	Export
	Clear
	Record
	Show Field
	
	
	About Oracle Applications

	Place on Navigator
	Delete
	Translations
	Hide Field
	
	
	

	Log on as a Different User
	Select All
	Attachments
	Move Right
	
	
	

	Switch Responsibility
	Deselect All
	Summary/Detail
	Move Left
	
	
	

	Print
	Edit Field
	Requests
	Move Up
	
	
	

	Close Form
	Preferences
	
	Move Down
	
	
	

	Exit Oracle Applications
	
	
	Widen Field
	
	
	

	
	
	
	Shrink Field
	
	
	

	
	
	
	Change Prompt
	
	
	

	
	
	
	Autosize All
	
	
	

	
	
	
	Sort Data
	
	
	

	
	
	
	View Query
	
	
	

	
	
	
	Reset Query
	
	
	


Retrieving Data (Queries)

	Query
	A query is a request to “pull up” certain sets of records in a database.  In Oracle, you can define and run a query based on the parameters of any field that you are able to navigate to and access in the various Oracle Applications forms.  In general, you do this by putting Oracle in query mode and then entering specific information into one or more of the input field(s).  The information that you enter tells Oracle the type and the range of information that you want it to search for and retrieve from the database.  There are two ways to create queries:


	The Find Mode
	


	Step
	Action

	1.
	Select View > Find  from the pull-down menu or select the Find icon with a flashlight [image: image35.jpg]


.  The Find form will change appearance depending on the application and base form you are working with.  Each Find form has fields relevant to your search.  

	2
	Enter you search criteria in the appropriate fields.  You can use the wildcard (%) character in the search phrase.

	3
	Click Find to find any matching records.


	The Query Mode
	


	Step
	Action

	1.
	Select View > Query by Example > Enter from the pull-down menu or press F11.
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The ENTER QUERY message will appear in the status bar in the bottom left corner of the screen.

	2
	Enter search criteria in any of the fields, using wildcard and query operators. You can also select Show Last Criteria to display the search criteria in your last search.

	3
	Select View > Query by Example > Run or press Ctrl + F11 to perform the search.


Continued on next page

Retrieving Data, Continued

	Query Operators
	

	Operators
	Meaning
	Example

	=
	Equal to
	= ‘Steve’ or = 107

	!=
	Not Equal to
	!= ‘Steve’ or != 107

	>
	Greater than
	>99.1 or > ‘Steve’

	>=
	Greater than or equal to
	>= 55

	<
	Less than
	<1000.00

	<=
	Less than or equal to
	<= 100

	#BETWEEN
	Between two values
	#BETWEEN1and 100


	Query by Example
	


	Step
	Action

	1.
	Navigate to the form in which you would like to conduct your count.

	2
	 Select View > Query by Example > Enter from the menu bar, or press F11, to put Oracle in query mode.

	3
	The Enter a Query message will appear in the status bar in the lower left corner of the screen.

NOTE:  You must complete this step (put Oracle in query mode) before you can define any search criteria for your count.

	4


	Navigate to the field(s) where you wish to define search criteria for your query.  Enter complete or partial values in these fields, to define the type of records that you wish to count.

NOTE:  In the above step, “partial” refers only to sets of values defined by wildcards, as described in the Wildcards section of this document.  If you enter a partial value without a wildcard, Oracle will not give you an accurate count for the data set that you are requesting.


Continued on next page

Retrieving Data, Continued

Query by Example (Continued)

	Step
	Action

	5


	Choose Count Matching Records from the View > Query by Example menu on the menu bar. A message will appear on the status bar, informing you of the number of records that would be retrieved if you ran the query at this point. Once you see the number of records, you can do one of the following:

· Run the query by selecting View > Query by Example > Run from the menu bar or press Ctrl + F11.

· If you only need to know the actual number of records or you do not wish to run the query at this time, take Oracle out of query mode by pressing F4 on your keyboard or by selecting View > Query by Example > Cancel from the menu bar


	Exiting out of Query mode
	


	Step
	Action

	1


	Once you run a query (View > Query by Example > Run) and Oracle retrieves the records that you have requested, it will exit out of query mode automatically.

· If you enter a query and you wish to cancel it before it runs, take Oracle out of query mode by pressing F4 on your keyboard or by selecting View > Query by Example > Cancel from the menu bar.  Oracle will return to its normal (input) mode.
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The CANCEL QUERY reminder will appear in the status bar in the bottom left corner of the screen


Accessing On Line Help

	On Line Help
	The Online Documentation and Help features can greatly enhance your ability to understand how to accomplish tasks using Oracle Applications.  You can also determine how to identify the user responsible for the entry or maintenance of the record for further clarification of a business issue.


	Help Menu
	


	Step
	Action

	1


	Select Help > Window Help  > Oracle Applications Library.  A Help window is displayed through your web browser tool, providing information and a list of topics associated with the current application window.
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Getting Help

Oracle Applications provides you with a complete online help facility

Whenever you need assistance, simply choose an item from the Help menu to pinpoint the type of
information you want

) To display help for a current window:

1. Choose Window Help from the Help menu, click the Help btton on the toolbar, o hold
down the Control key and type '

A web browser window appears, containing search and navigation frames on the left, and a
frame that displays help documents on the right

The document frame provides information on the window containing the cursor. The
navigation frame displays the top-level topics for your responsibility, arranged in a tree
cortrol

2. Ifthe document frame contains a list of topics associated with the window, click on a topic
of interest to display more detailed information

3. You can navigate to other topics of interest in the help system, or choose Close from your
web browser's File menu to close help

Example
Suppose you are using Oracle General Ledger and are in the Define Budget Organization

window. You wart to know how to create a buidget organization using this window. Choose
Window Help from the Help menu to display a help on this topic.





· The Glossary provides help information by topic, alphabetically.  The information contained in the Glossary is primarily a brief description of each topic.

· Navigation Help provides information of the navigation paths to forms within each Oracle application.

· The Library icon gives you access to online Help for any Oracle Application products and complete reference and documentation of the products


 Folders Tools

	Folders
	Folder Tools are available in the Personnelists and Federal HR Manger roles.

A Folder is a special block in which the field and record layout can be customized. A folder block lets you satisfy the following basic customization needs:

· Display only those fields that are of interest to you.

· Instantly modify the width, sequence, and prompts of the fields you want to display.

· Display a subset of records based on your specific criteria.

· Display records in a specific order.

· Save your folder customizations for later use.

· Automatically query for a subset of records each time you open a specific folder.

· Keep your folder customizations private or make them public for others to access.

· Make your customizations the default layout for a folder block. 




	Folder Tools
	When you navigate to a folder block, the Folder Tools button gets enabled on the toolbar.  Choose this button  [image: image39.jpg]&



 to display the folder tools palette on your screen. 

The folder tools include the following buttons that replicate the actions of some commonly used Folder menu items:


	Buttons
	Function

	 [image: image40.jpg]


 Open Folder
	Open another folder.                

	 [image: image41.jpg]


 Save Folder
	Save the current folder.

	 [image: image42.jpg]


 Create New Folder
	Create a new folder

	 [image: image43.jpg]


 Delete Folder
	Delete an existing folder

	 [image: image44.jpg]


 Widen Field
	Increase the width of a field

	 [image: image45.jpg]


 Shrink Field
	Decrease the width of a field

	 [image: image46.jpg]


 Show Field
	Show a currently un displayed field


Continued on next page

Folders Tools Tools, Continued

	Folder Tools (continued)


	Buttons
	Function

	[image: image47.jpg]


 Hide Field
	Hide a currently displayed field.
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 Move Left
	Swap the current field with the field to its left in a multi–record block. In a single–record block, move the current field one character width to the left

	[image: image49.jpg]


 Move Right
	Swap the current field with the field to its right in a multi–record block. In a single–record block, move the current field one character width to the right
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 Move Up
	Move the current field up by one character height for a single–record display
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 Move Down
	Move the current field down by one character height for a single–record display


Continued on next page

Creating a Folder

	Folder Window
	


	Step
	Action

	1
	Navigation Path →View → List →People Folder
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NOTE: Any window listed under the View, List navigation is a folder window and the following procedures work the same for all 

	2
	Select   Folder > New.  You will see a Create New Folder window.
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	3
	The create New Folder window opens: Enter a new and unique folder name.
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Continued on next page

Creating a Folder

	Folder Window
	

	Step
	Action

	4


	Select the Auto query option you require.
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 NOTE:  You must be very careful in assigning the Autoquery option.  The basic rule is that the folder should behave the same as the standard screen.  If, when you enter the standard screen, data is automatically displayed, set the autoquery option to “Always”; if it is not, set the option to “Never.”

	5
	Check Open as Default if you want this folder definition to open as your default every time you invoke the form. 

 [image: image56.png]i Open as Defauit





	6
	Check Public if you want other users to have access to this folder.
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	7
	Click the <OK> button when you are finished


Continued on next page

Creating a Folder, Continued

	Defining Folder Query Criteria
	One advantage of a folder is that you can customize it to display only the records you want to see.  You can easily define and alter the query criteria for any folder and save those criteria in a folder definition


	Step
	Action

	8
	Run the query by Pressing the F11 key, Enter the Search Criteria and press both the F11 and the CTRL buttons.  At least one record has to be retrieved for the folder to memorize the query.
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	9
	After the query has completed click Folder > Save.  This query is saved in a folder definition
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	10
	Verify this folder has been saved with the parameters you have selected. Click <Folder> <Open>. The open folder window will appear with the Name of the folder and creator.  

[image: image60.png]




	11
	You can query your folder in this window with the specific parameters given. And if you choose you can reset the query criteria by selecting Folder > Reset Query


Exporting Data

	Exporting Data
	You can export Data from any of your Views (Folder windows)

	Step
	Action

	1
	While in the Folder window you have completed the query, arranged the columns to your needs. From the main menu Click <File> <Export> This will be the data you want to export.
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	2
	If there are several hundred records to be retrieved a Decision box will appear click the <Continue> button.   
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NOTE: This will occur after every 100 records retrieved, to avoid having to click the continue button several time, Click the <Continue to End> button to expedite query.

	3
	A Progress box will appear showing the percentage of data being exported. 
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Continued on next page

Exporting Data, Continued
	Exporting Data
	(Continued)


	Step
	Action

	4
	After the export is complete a File Download window will open. You have a choice of Save the File to disk or Open this file from the current location. Click the <OK> button.
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	5
	Save this file to disk will – Allows you to save file to a particular format for viewing at a later point.  
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	6
	When opening the file the Program window will appear: Highlight EXCEL and click the<OK> button.
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The data you exported will now be imported to an excel spreadsheet save the file with a .XLS file extension to the directory of your choice. 

NOTE:  The file will download as a text delimited. Change the file type before saving the file to your directory.


 Using Date Track 

	Accessing Date Track
	


	Step
	Action

	1
	From any window that contains “date tracked” information, click on the DateTrack button on your Oracle toolbar.  The button is located near the right end of your toolbar, and it looks like this:  


Or access DateTrack by using the menu bar commands Tools, Alter Effective Date. Once you perform one of these two actions, DateTrack’s Alter Effective Date window will appear.

	2
	Enter the effective date that you wish to create for your database in the Effective Date field of the Alter Effective Date window and click OK or press Enter.

Oracle will exit out of the Alter Effective Date window and return to the original window. The new date will appear in the title bar of the as pictured in the illustration.  [image: image67.png]eople: 01-AUG-2002




Once the effective date is altered, all information entered, changed, or viewed will be treated as if it were being accessed on that altered date.


Viewing Date Track History

	Date Track History
	Date Track History shows all of the changes that were made to a date tracked record over time.


	Step
	Action

	1
	Click on the DateTrack History icon on far right end of the toolbar.  [image: image68.bmp]  Or 

Click <Tools> in the menu bar and select  Date Track History. [image: image69.png]Aler Effective Date.
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	2
	Each row in the DateTrack History Change Field Summary window shows a field in the record that was changed on the effective date (i.e., the date that is displayed in the From field of the form currently initiated).
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Click the <Full History> button in the DateTrack History Change Field Summary window.


Continued on next page

Viewing Date Track History, Continued

	Date Track History
	(Continued)


	Step
	Action

	3
	The full history summary of the current record will appear, showing all of the fields and the date(s) when information was changed.  The information that corresponds to the effective date originally entered in DateTrack will be highlighted.
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	4
	To exit out the DateTrack History Change Field Summary and/or DateTrack History of Person window, click on the X in the upper right-hand corner of the window.  Returning to the original window [image: image72.bmp]


Closing Oracle Applications

	Closing Applications
	


	Step
	Action

	1
	Using the menu bar click <FILE> - Exit Oracle Application. 
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	2
	The following caution message will appear – click the<OK> button to exit:
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Close all remaining browser windows related to Oracle.


Request for Personnel Action (RPA)

	Accessing the RPA
	


	Step
	Action

	1


	Navigation Path → Req Personnel Action → Appointment → Open.  

Note:  Refer to section, “Helpful Function Keys and Icons” in this Guide for an explanation or description of the Toolbar Icons. 
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	2
	There are four tabs across the top:
· Requesting Info 

· Position Data 

· Employee and Position Data 

· Remarks and Address 


	Completing the RPA
	

	Step
	Action

	1
	Complete the data fields on Requesting Info Tab, using the “pop lists” attached to each data field.  

	2
	Proceed to the next tab until the RPA is complete.

	3
	Save.


Continued on next page

Request for Personnel Action (RPA), Continued

	Completing the RPA (continued)


	Step
	Action

	4
	Click the <Extra Information> button.  The Extra Information Flexfields opens:
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	5
	Click on US Fed Agency Data.  Click in the Details Box.

The Extra PA Request Information Flexfield displays with information in the appropriate fields:

[image: image77.png]





	6
	Click on US Fed Payroll Type.  Complete the data entry and complete the remaining flexfields.

	7
	Save and Route.


Workflow Inbox

	Accessing the Workflow Inbox or Worklist
	Your system administrator must add the Workflow Inbox to the menu for a responsibility assigned to you before you can access it and view your Worklist.  It is used to manage your RPAs and Notifications, i.e., HR updates, WGI Notices, etc.  For example, a Mass Realignment will display a notice on each employee realigned.

· It lets you choose which notifications to display and what information to display for those notifications. 

· In addition to the preconfigured Worklist viewing options, you can create personal Worklist views by defining a set of filtering criteria to  determine what types of notifications and properties to display.  

· You can:

· Perform one-time searches to locate notifications you want to view.

· Save the search criteria as a personal Worklist view to repeat the same search later.  
· Respond to your notifications. 
· Reassign notifications to another user. 
· Request more information about a notification from another user, 
            and define automatic notification routing rules.

Note:  Your System Administrator can turn off notices that may fill up your viewing space in the inbox, such as notices for the manager to approve an RPA; a  Personnelist to approve an RPA, and Auto WGI notices.

	Step
	Action

	1
	Navigation Path → Workflow Inbox → Open.  
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Continued on next page

Workflow Inbox, Continued

	Accessing the Workflow Inbox or Worklist (continued)


	Step
	Action

	2
	The Worklist window opens:
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	Worklist Window Description
	The features associated with this new inbox for viewing and responding to notifications are:

· Simple and advanced searches

· Customized views (Personalize)

· Open and reassign

· Creating routing rules to manage your notifications




	Buttons/Links
	Function

	Logout
	To be developed.

	Preferences 
	Displays a General Preference Window – not currently used.

	Help
	Assists with the window.

	View
	List of preconfigured views.

	Go
	Execute the search to review the results.

	Personalize
	Creates a custom view

	Simple Search
	Locates a one-time search of notifications that match your criteria


Continued on next page

Workflow Inbox, Continued

	Worklist Window Description (continued)


	Buttons/Links
	Function

	Open
	Opens the selected notification.

	Reassign
	Currently not available.

	Select All
	Selects all notifications on the current page using check boxes.  

	Select None
	Deselects notifications.

	Next
	Allow you to view next 25 notifications for the preconfigured views.  (Customized views can be set for a different number to view.)

	Columns
	Allows you to sort the columns by clicking on the desired column.  By default, the list is sorted by sent date from most recent to oldest, and then by subject in alphabetical order.  For example, click on Subject and the notifications are sorted alphabetically by subject, i.e., all the cancellations are listed together, and all the corrections are listed together, by Sent date.

	
	
	From
	The role from which the notification was sent.
	

	
	
	To
	The role to which the notification was sent.
	

	
	
	Type
	Displays name of the item type of the notification:

· Federal HR-Personnel Action (RPA), 

· OTA Training Request Forms.
	

	
	
	Subject
	Description of the notification.
	

	
	
	Sent
	Date when the notification was delivered.
	

	
	
	Due
	Date by which the notification should be completed.
	

	
	
	Status
	Shows “Open,” “Closed,” or “Cancelled.”
	


Continued on next page

Workflow Inbox, Continued

	Viewing the Details of a Notification
	


	Step
	Action

	1
	Navigate to the full details of a notification by clicking on the notification’s underlined Subject link. Or check the select box and the click the <OPEN> button.
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	2
	The Notification Details window opens:
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· If you revisit a notification to which you have already responded, the Response section indicates that the response has been submitted, and displays the response values that were submitted.

· If a notification does not require a response, the Response section indicates that as well. Choose the Close button in the Response section to close the notification so that it does not appear in your Worklist the next time you view your open notifications.


Continued on next page

Workflow Inbox, Continued

	Viewing the Details of a Notification (continued)


	Step
	Action

	3
	Click on the attached form icon in the Response section to act on the notification.
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	4
	The Launching Form window displays:
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You can choose <Keep Window> to continue displaying the launch window. Otherwise, this window automatically closes after 30 seconds.

	5
	The Request for Personnel Action form displays with the details of the selected notification. 
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Note:  If the RPA does not open when selected, it might be “minimized” and you have to click on the Oracle Application at the bottom of your desktop to retrieve it.

	6
	Enter your information.  Save and route the RPA.  Or, if you need more information, close. 


Continued on next page

Workflow Inbox, Continued

	Viewing the Details of a Notification (continued)


	Step
	Action

	7
	To request additional information for an RPA, click on the More Information link. 
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	8
	The Request More Information window displays:
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	9
	Select Any User, and click on the flashlight. The Search and Select List of Values window is displayed:
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Continued on next page

Workflow Inbox, Continued

	Viewing the Details of a Notification (continued)


	Step
	Action

	10
	Choose Search By, Display Name on the drop down list, and enter a value for the display name using the wildcard (%) to search, if necessary. Click <Go> to view the results of the search.
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	11
	In the Results section, select a name by clicking on the underlined Display Name.  The Request More Information window displays with the selected User Name.  Enter your remarks in the Information Requested section.  This datafield is required as indicated by the sterisk.
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Continued on next page

Workflow Inbox, Continued

	Viewing the Details of a Notification (continued)


	Step
	Action

	12
	Click <Submit>.  The request is sent to the specified user.  The user opens up the notification and the following displays:
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This History line shows who the request was sent to along with comments from the sender.  The receiver then clicks on the Response Icon.
You can also select  <Cancel,> to return to the previous page without sending the request.  After you request more information for a notification, the notification does not appear in your Worklist as an open notification until the user responds to your request.  However you can still view the notification by selecting the view Notifications From Me from the Worklist window.

· If you do not want to wait for the additional information requested, you can respond to the notification using the Response section of the Notification Details page. In this case, your pending request is cancelled.

· If you want to request more information from a different user, you can submit a new request using the <More Information> button in the Response section of the Notification Details page. In this case, your initial request is replaced by the new request, and only the user to whom you sent the new request can respond with more information.


Continued on next page

Workflow Inbox, Continued

	Simple Search
	

	Step
	Action

	1
	On the Worklist Window, click the<Simple Search> button.  The Simple Search window opens:
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	2
	Enter your search criteria to locate specific notifications.  The search options are Subject, From, and Sent.  The Simple Search window will displays with that search data field populated.

[image: image92.png]Simple Search

LR p—— _ aamcsasaes | vos
o —

L ——

P —]

ey
T Fudwl - Pesomel cion Ut 1B Cante EPA Can 10 Cane Cod Aspoinen FesUOCTIES] 24002 01
75 Rutect o atowsond o b g e





	3
	Click <Go>.


Continued on next page

Workflow Inbox, Continued

	Simple Search (continued)


	Step
	Action

	4
	The Simple Search window displays the notifications that match your criteria including those that are closed.  Click <Save> to save your search for a future view.  If this search does not provide enough parameters, you can go to the <Advanced Search> for additional features.
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Note:  The total number of records that match your criteria is indicated above the notifications list.


	Advanced Search
	


	Step
	Action

	1
	On the Simple Search window, click the <Advanced> button.  The Advanced Search window opens:
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Continued on next page

Workflow Inbox, Continued

	Advanced Search (continued)


	Step
	Action

	2
	Select one of the options for locating specific notifications.

Select one of the two radio buttons:

· “Show table data when all conditions are met.”  (Results in  notifications that only met all of your criteria.)

· “Show table data when any condition is met.”  (Results in notifications that match at least one of your search criteria.)

	3
	To select notifications that meet all conditions, click the first radio button.
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	4
	You have the ability to add additional columns to your search by clicking on the drop down arrow beside the “Add column” field, selecting the desired field and clicking the Add button.
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Continued on next page

Workflow Inbox, Continued

	Advanced Search (continued)


	Step
	Action

	4

(Cont)
	When the window repopulates you will see the selected field now as a part of the search criteria.  
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	5
	In the Subject drop down list, select “contains.”

	6
	Enter “Realignment” in the subject data field.

	7
	In the Sent drop down list, select “after” and enter the date.

	8
	Click <Go>.  The Advanced Search result displays:

[image: image98.png] Fedoral KR - Persennel Acton

 Fedonl R - Pasomel Acin . eslonment Rt WRERRS02004
Fodoral R Porsomel Actin __ RPA. Realgoment . Regt WRERESZE!
STl






	9
	You can save this search criteria for future use by clicking the <Save Search> button at the bottom of the Worklist.  The Create View window displays.  Follow the procedures for creating a view if desired.  See Personalized View in this section for details.


Continued on next page

Workflow Inbox, Continued

	Personalized View
	


	Step
	Action

	1
	The Worklist window defaults to “Open Notifications.”  There are four other preconfigured views on the drop down list:  

· All Notifications 

· FYI Notifications (Includes those not routed for approval)

· Notifications From Me (Only those you generated)

· To Do Notifications (Require actions)
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	2
	Use any of the preconfigured views, or create your own view.  Click the <Personalize>button.  The Personal Worklist Views window opens:

[image: image100.png]Personal Worklist Views

Belowis alist of al pre-configured andior personalized iews appiicable to “Workiist" table on the previous
screen.

Fronovs [ 15015 3] tioxt:

© Al Notfcatons 002002
= o10c20m2. No
g o .&Tx"‘ ;:mm
T i
€ To Do Natcations. 01002002 Mo,
‘Retum to Worklist. Create View







Continued on next page

Workflow Inbox, Continued

	Personalized View (continued)


	Step
	Action

	3
	· You can duplicate one of the preconfigured views by selecting one of the views and clicking the <Duplicate> Button.

· Or you can create your own view, by clicking on the Create View Link at the bottom of the window.

	4
	To duplicate a preconfigured view, select the view to duplicate, i.e. 

Open Notifications.  Click the <Duplicate>. button  The Duplicate View window opens:
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	5
	In the General Properties section, enter a View Name, Number of Rows to be displayed, and a Description. If you would like this view to be the default view when opening the Worklist, check the Set as Default box (currently not working.)

Under Column Properties, update the columns to be displayed, and the order in which they are displayed, as needed.
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Continued on next page

Workflow Inbox, Continued

	Personalized View (continued)


	Step
	Action

	6
	· Use the Sort Settings section to modify any of the default settings for your custom view.

· To specify additional parameters and values to filter data, make changes in the Search Query to Filter Data in your Worklist section.
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Click on the <Apply> button when finished to save the new view.

	7
	The Personal Worklist Views Window displays, and the list of views now includes the new custom view, My Open Realignments.  Click on the Return to Worklist link to select and view the results of My Open Realignments.
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Continued on next page

Workflow Inbox, Continued

	Personalized View (continued)


	Step
	Action

	8
	After selecting My Open Realignments view, the results display:
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	9
	To create your own custom view, click on the <Personalize> button from the Worklist window.  The Personal Worklist Views window opens. 
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Click on the underlined Create View link.

	10
	Follow the instructions for Duplicate view (Steps 4 – 6), to create a new custom view.


Continued on next page

Workflow Inbox, Continued

	Creating Routing Rules
	You can create customized routing rules for automatic notification processing.  For example, you can route certain types of notifications to a co-worker for coordination.  


	Step
	Action

	1
	On the Worklist window click the underlined routing rules link at the bottom of the window:
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	2
	The Notification Routing Rules window opens:
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	3
	Click on the underlined Create Rule.  The Activating Type of Notification window opens:
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	4
	Choose a type of notification from the drop down list:
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Note:  If you choose “All” you can skip to Step 3 Next at the lower right corner.


Continued on next page

Workflow Inbox, Continued

	Creating Routing Rules (continued)


	Step
	Action

	5
	Click the <Next> button.  The Rule Response window opens:
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	6
	Enter values in the Start Date and End Date fields to specify the period that this rule should be active.  

· If you leave the Start Date blank, the rule is effective immediately.  

· If you leave the End Date blank, the rule is effective indefinitely.  

CAUTION:  Since you can define different rules for the same notifications to be effective at different time, the system allows you to define multiple rules for the same notifications.  

· You should be careful to ensure that rules for the same notifications do not overlap in their effective dates.  

· If multiple rules are effective for the same notification, Workflow picks one rule at random to apply.

	7
	In the Message field, enter any text that you want to append to the notification when the rule is applies.  

Note:  “Reassign to” is currently under development. 

	8
	Choose:

· <Submit> to save the rule,  

· <Cancel> to return to the Worklist without creating or updating the rule, or,

· <Back> if you are creating a new rule, to return to the previous page.


Position Window

	Introduction
	There are new features to the Position area:  

· Position history is now date tracked.  It allows you to:

· Query the position at a certain date,

· View the past changes made to the position, 

· Make multiple changes on the same day.

· Correct – Changes back to date the position was established;

· Update – Changes from this date forward.

· Position Type on the Position Details Tab contains new data:

· Single Incumbent (Defaults to all new positions)

· None (Reflected in converted records – need to be changed to Single Incumbent) 

· Pooled (Not currently used)

· Shared (Not currently used)

· On the Hiring Information Tab, Full Time Equivalent (FTE) and Headcount default to “1.”  (You can change the FTE for reports.)

· Updatable data fields are yellow and white; gray fields are not used by DoD.

· When you delete positions, the sequence numbers are recycled and are used again.

· Position Name is now Date Effective Name, so you can use date tracking and view the position name as of that date.


	Accessing the Position Window
	

	Step
	Action

	1
	Navigation Path, Work Structure →   Position → Description → Open.  
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Continued on next page

 Position Window, Continued

	Accessing the Position Window (continued)


	Step
	Action

	2


	The Find Positions window opens.  
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This window is a new feature that provides an easy method to retrieve a blank Position window for building a new position, and for querying current positions in the data base.  

· You can query on any of the data fields associated with the Name (now Date Effective Name) data fields.

· You can use the Sequence Number.

You don’t have to use the periods to separate data, i.e., “.”“PERSONNEL%” is now just “PERSONNEL%.”

Note:  Do not click the <Find> button without entering data in one of the fields.  It causes a lengthy delay while the system searches the entire position data base.




Continued on next page

Position Window, Continued

	Accessing the Position Window (continued)


	Step
	Action

	3
	On the Find Positions window, click in the name data field.  

All fields should be blank before entering your query,  A query can be performed on any of the data fields
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	4


	Enter search criteria in an appropriate field followed by a % sign.  For example, in the Title data field, enter “PERSONNEL%,” to retrieve all positions with “PERSONNEL” in the Title.  
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NOTE:  The fields are case sensitive.  If the Title was built with all caps, you must use all caps when entering the Title information.


Continued on next page

Position Window, Continued

	Accessing the Position Window (continued)


	Step
	Action

	5
	Click the <OK> button.  The Find Positions window opens with the info in the Name data field:
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	6
	Click the <Find> button.  The Position Window opens with the first position that matches your criteria:
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The message bar at the bottom of the window displays “Record: 1/?” indicating there is more than one record.  Use the Up and Down Keys to search for the position you need.


	Building a New Position
	

	Step
	Action

	1
	If you need to build a new position, 

1. Click the <New> button.  The Position Window opens.  

2. Enter the information in the Position details tab and the Others button.  

3. Validate and Save.


Continued on next page

Position Window, Continued

	Querying a Current Position
	


	Step
	Action

	1
	If you need to view a current position, or make changes to a current position, you can use the usual query method:

1. Close the Find Positions window.  The Position Details window opens. 

2. Press F11 key (prior to clicking anywhere on the form), to query the position.

3. Enter the name of the position in the Date Effective Name data field, for example:  “.PERSONNEL%”.

4. Press Ctrl and F11 keys simultaneously.  The first position with the query criteria displays.  

5. Scroll to the position using the Up and Down Keys.  When the desired Position window displays, make the changes on the appropriate tabs.  

6. Validate and Save.


	Position Window Description
	The Position Window opens with the Position Details Tab open.  Click on the other three tabs to display:  Hiring Information, Work Terms, and Additional Detail, which are not being used by components at this time.




	Tab
	Example/Description

	Position Details

Proposed End Dates are Optional
	[image: image118.png]St 5 0cT 202
Date Efect Name |

Type [Single ncumbent @ Bemanent " Seasanal

- Ongonicaionadob - B
i

Organiztion Progosed End Date








Continued on next page

Position Window, Continued

	Position Window Description (continued)

	Tab
	Example/Description

	Hiring Information
          (Full Time             

          Equivalent)
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	Work Terms
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	Additional Detail
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Continued on next page

Position Window, Continued

	Taskflow Buttons
	There are five taskflow buttons on the Position Window:




	Taskflow Button 
	Example/Description

	<Validate>
	When you click the Validate taskflow button, the system performs the necessary edit checks and updates the database with the new information.

	<Occupancy>
	Displays the employees who have occupied the position, plus their start and end dates.  
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If you want to view the employee’s record, you can highlight the name and click the <Person> button at the bottom of the window.

	<Extra Information>
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Continued on next page

Position Window, Continued

	Taskflow Buttons (continued)

	Taskflow Button
	Example/Description

	<Extra Information> (Cont)
	· The fields include the data items required to pass the Central Personnel Data File (CPDF) edits, as well as optional position data items required by each component.  The system supplies values from the data base for those data items completed earlier in the position build or by direct data entry.

· To view or enter Extra Information data, highlight the Type of information and click in the Details Field.  

	<Reporting To>
	This button displays the Hierarchy and Position Name information.
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	<Others>  
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Continued on next page

Copying a Position

	Introduction


	Position Copy reduces the time and effort required to create positions and ensures accurate data.  It allows you to:

· Specify criteria for finding and selecting positions.

· Use existing positions and create new ones making minor or major changes to the position definition.

· Copy a specific position or retrieve all positions that correspond to the criteria.

· Preview the results before creating the final copies.

· Save the set of positions (unlimited) and continue working on it at another time, i.e., when you have received all the information required to complete the position definitions.

Note:  It is now possible to copy invalid positions.  Be sure the status is “Valid” before copying.


	Accessing the Position Copy Window
	

	Step
	Action

	1
	Navigation Path →Work Structures → Position → Position Copy.  The Position Copy window opens with two tabs, Original and New:  
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Continued on next page

Copying a Position, Continued

	Entering Selection Criteria
	You can copy a specific position or retrieve all positions that correspond to the criteria.

	Step
	Action

	1
	In the Position Copy window, enter a unique name in the Name data field to identify the set of position(s) to be copied.  Enter a name even if you are going to copy only one position. 
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 For Example, use your initials, date, Position Title, etc.  

	2
	The Effective Date populates with the current date.  

· It applies to all the positions that you query. If you do not enter a date, the system uses the current date.

· Change the Effective Date if you want a date that corresponds to the position to be copied.  

	3
	In the Position window click in Position Name data field.

 [image: image128.png]Pasition Name




 The Position Flexfield window opens with the Sequence Number populated:


	Selecting a Position to Copy
	There are three ways to query a position on the Position Flexfield.  
· Enter part of the data, with or without using the <Combinations> taskflow button:

· Entering a Sequence Number produces only one position;

· Entering a Title produces a list of all positions with that title;

· Select all positions by Job, Organization, or Location:

· Entering a Job and an Organization, i.e., you can produce a list of all engineers in a certain organization. 

· Enter information in all the data fields.


Continued on next page

Copying a Position, Continued

	Query by Sequence Number 
	Follow these steps to retrieve a single position, using the Sequence Number of the position:


	Step
	Action

	4
	Enter the Sequence Number you whish to query and click the <OK> button.

	5
	  The Criteria Flexfield opens Click the <OK> button.

[image: image129.png]= Criteria

o I






	6
	The Position Copy window opens with “Pending Query” in the Status data field at the top, and Position Name populates with the Sequence Number under the Selection Criteria.

	7
	Enter the number of copies needed in the Default Copies data field.

[image: image130.png]Default Copies 1]





	8
	Click the <Query> button. [image: image131.png]Query





	
	The Position Copy window displays the retrieved record(s) in the Status data field.  The position data populates in the columns:  Copies, Position Name, Status, Job Description, Organization Description, Hiring Status, etc.

Note:  The number of copies you entered displays under Default Copies data field and the Copies Column.


Continued on next page

Copying a Position, Continued

	Completing the Position Copy
	

	Step
	Action

	9
	Click on the New Tab.  [image: image132.png]New





	10
	Click in the Change List data field. 
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	11
	The Change List window opens: Change any of the data fields that apply to the new position(s).    Click the <OK> button.
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	12
	After making all necessary changes click the<Create New> button on the upper right side of the window.
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	13
	A Note Message Box displays:  “Pending record(s) created on New Tab.”  Click the <OK> button.

	14
	The New window Tab displays the Position data populated in Position Name data field and the Columns populated with the number of positions to copy.  The Status data field at the top populates with “Pending New Record(s).”

	15
	Click the <Submit> button at the bottom of the window.

	16
	A Note displays:  Transaction applied and concurrent request _(#)____ submitted. Click the <OK> button. 

	17
	Go to the Position screen, Query the new position and validate it. 


Continued on next page

Copying a Position, Continued

	Completing the Position Copy (continued)


	Step
	Action

	18
	If the position copy is in the status of “Error New Record(s),” follow procedures for Viewing the Process Log. 

· When the position copy is submitted, the system refreshes the position data with the exception of the Change List items and any manual changes you’ve made.  It refreshes the data based on the Effective Date.  

· The system validates the position using the same validation process it does when you create a position with the Position Window.  

You can query the new position in the Position Window and continue making further changes, for example, in Position Extra Information.

	19
	Re-query the position copy name (Personnelist Position Copy) to refresh the status.  Press F11, type in Personnelist%, CTRL+F11.  The status changes to “Completed.”
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Continued on next page

Verifying the Position
	Viewing the Process Log
	If the status is “Error New Record(s),” use the Process Log to view the error message associated with the position copy.  The Process Log also includes Position Copy transactions that completed successfully.

	Step
	Action

	1
	Navigation Path → Federal Maintenance Forms →  Process Log.  The Process Log Navigator window opens:
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	2
	Under View, click on the drop down list to select Position Copy view.
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Continued on next page

Verifying the Position, Continued

	Viewing the Process Log (continued)


	Step
	Action

	3
	Click on the plus sign (+) next to Position Copy to view the list of Position Copy transactions.

· Green Light indicates “Copied”

· Red Light indicates“Errors”

The error message is shown on the right under Message.  This error is related to invalid data associated with the original Position being copied.  You need to correct this information on the Position window, and then go back to Position Copy.   

· Re-query the Position Copy transaction that is in status of Error New Record(s). 

· On the Original Tab, click Query. This retrieves the original position with the correct data. 

· Click on New and continue with the position copy.



	4
	You may delete a position copy transaction if the status is Pending New Record(s) or Error New Record(s).  Once the status is Completed, you are not able to delete the transaction.




People Window

	Accessing the People Window
	


	Step
	Action

	1
	Navigation Path ( People (  Enter and Maintain.  The Find Person window displays:
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	2
	If you are building an applicant, click the <New> button.  The People window displays.  Complete the data fields.

	3
	If you need to make a change to an employee record or view the information in the Person Summary, click the LOV at the end of the Full Name data field on the Find Person Window.    

	4
	The People –Find window displays.  

· Enter a % sign to view all the names in the data base, or

· Enter the first letter of the last name with a % sign.  For example:  “A%” displays all last names starting with an “A.”
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Click the <Find> button


Continued on next page

People Window, Continued

	Accessing the People Window (continued)


	Step
	Action

	5
	The People – Find Window displays with a list of names and Employee/Applicant Numbers.  Select the name, and click <OK>.
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	6
	The People window displays the data fields automatically populated.  There are nine tabs and five taskflow buttons.  The Personal Tab displays first.
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Continued on next page

People Window, Continued

	People Window Description
	


	Tab
	Example/Description

	Personal
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	Employment:
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	Office Details
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	Applicant
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	Background
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	Rehire
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Continued on next page

People Window, Continued

	People Window Description (continued)


	Tab
	Example/Description

	Medical
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	Other
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	People Window Taskflow Buttons 
	The People Window has five Taskflow Buttons:

· Address

· Extra Information
· Assignment (has six tabs)

· Special Information

· Others (with Navigation Options including the Person Summary)




Person Summary

	Accessing the Person Summary
	


	Step
	Action

	1
	Navigation Path ( People (  Enter and Maintain.  The Find Person Window displays. (For examples, refer to Accessing the People Window in this guide.)



	2
	Click the LOV at the end of the Full Name data field.

	3
	The People –Find Window displays.  

· Enter a % sign to view all the names in the data base, or

· Enter the first letter of the last name with a % sign.  For example:  “A%” displays all last names starting with an “A.”
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Click the <Find> button

	4
	The People – Find window opens with list of names and Employee Numbers.  Highlight the name and click <OK>.
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	5
	The Find Person window displays the Employee Name, and Number:

[image: image154.png]



Click the <Find> button.


Continued on next page

Person Summary, Continued

	Accessing the Person Summary (continued)


	Step
	Action

	6
	The People window opens:
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	7
	Click the <Others> button.  The Navigation Options window opens:
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	8
	Select Person Summary and click the<OK> button.


Continued on next page

Person Summary, Continued

	Accessing the Person Summary (continued)


	Step
	Action

	9
	The Person Summary window displays three tabs (Person Information, Person:  Military/Education, and Assignment Information):  
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	Person Summary Window Description
	There are 12 tabs on the Person Summary Window.  Nine more tabs are available when you click the arrows to the right of the tab headings:




	Tab
	Example/Description

	Person Information
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Continued on next page

Person Summary, Continued

	Person Summary Window Description (continued)


	Tab
	Example/Description

	Person Military/

Education
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	Assignment

Information
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	Assignment Probation/

Retained Grade
	Click the arrow box to the right to display remaining tabs:
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Continued on next page

Person Summary, Continued

	Person Summary Window Description (continued)


	Tab
	Example/Description

	Position:  

Title/Pay 

Prev/Grade, Etc.
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Person Summary, Continued
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Person Summary, Continued
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